<< return to Vizycam.com

New Vizy release!

Hey Everybody,
Please check out the latest and greatest. Most of the development for this release was getting the feature set of MotionScope rounded out. Enjoy!


I’ve been playing around with 0.1.100 - trying out the new version of MotionScope. It seems to work pretty well. The app captures / processes / analyzes video and the results look reasonable. Saving / Opening files works too.

But … the computer and browser that you connect to the Vizy with can have a huge influence on what you see.

My main computer is a Mac and I use the Safari browser. But I have issues seeing video from the Vizy in Safari even though I’ve done this: https://docs.vizycam.com/doku.php?id=wiki:enable-webrtc. So I’ve been connecting to Vizy via the Chrome browser from another Raspberry Pi. But that doesn’t work well at all for MotionScope - lots of video freezes and slow click responses. Instead, for MotionScope I found that the Chrome browser on the Mac works very well. Hope this helps someone else.

Good job on this release! Looking forward to the next one!

Hi Ed,
With Safari, are you not seeing any video, or does the video have other issues?

I’m guessing this isn’t a regression from 0.1.98 (Is that what you’re saying?)

thanks :slight_smile:


I didn’t see any video at all with Safari in 0.1.100. I too guess it’s been that way - I stopped using it with Vizy a while ago and only tried it again because my normal setup (Raspberry Pi / Chrome) wasn’t working well with the new MotionScope.

I have a good work around, but If you want, I’d be happy to try and debug it with you.

Hi Ed,
I’m wondering if this is Safari of MacOS version issue. It seems to work well on this end (Safari MacOS and IOS).

We recently upgraded our only (old) Mac – here’s what we’re using:

Image 959



Thank you very much for getting me to look at this again!

It turns out that it was a Safari preference setting.

I had Safari -> Preferences -> Websites -> Auto-Play defaulting to “Never Auto-Play”. When I changed it to “Allow All Auto-Play” for the Vizy server, it worked.

Sorry about any confusion, but maybe this will help someone else too.

Nice find! We’ll add this to the docs. :slight_smile:

Setting the “other website” to “stop media with sound” works too.


1 Like