<< return to Vizycam.com

1st Impressions and some issues I had

I posted this on kickstarter, but will duplicate here.

I used my phone to setup the WiFi, I found it to be a bit tricky to get setup. Using a Motorola G Stylus Android 11.
1st issue: I wasn’t able to use http://vizy.local and had to use a network scan tool to find the vizy. Using the IP address in the mobile browser worked without a problem.
2nd issue: for some reason my 2Ghz connection showed in the list, but my 5Ghz connection did not show up (multiply refreshes), my neighbors 5Ghz and a couple others showed up, so I’m not sure what the issue was. Using “Other” and putting in my 5Ghz SSID also did not work.
3rd issue: when typing in the WiFi password it gets doubled and setup fails, it took a few tries to finally get it to work, and I had to erase the doubled part (also, the password is displayed in the clear)
4th I can only connect to the 2Ghz side of my router - this may or may not be related to my 2nd issue.

Once I got the Vizy to connect I had one more issue.

Linux Min 20.2, with Chrome browser 93.0.4577.82 on a I5 machine, the Vizy came with software version 0.0.75.
I did not get any video until I updated to Vizy 0.0.76 which was easy enough to do.

The wiki seems to suggest the no video is a windows issues - It may not just be windows that has this issue.
0.0.76 appears to have fixed it, so may just need to update the wiki page

The few examples all appeared to work after 0.0.76


Sorry for the problems!

Some devices don’t have mdns/Bonjour. Windows, IOS, MacOS support it. Linux may need to be configured to support, but I’m guessing mdns/Bonjour support is usually installed. This may be common with Android devices, we don’t have a lot of datapoints with Android.

The 5ghz problem is interesting – it could be a localization issue: https://www.raspberrypi.org/forums/viewtopic.php?t=261777
I’m not sure if you feel comfy running raspi-config, etc, but this would be good info.
When you say that the password gets doubled, that’s something we haven’t seen. You’re saying that if you type an “a”, you see 2 "a"s? This is definitely something we need to reproduce asap. Could you try a different OS/browser and see if the problem goes away? Please tell us which browser and OS you were using.

We’re trying to make Vizy (and Raspberry Pis running our software) as easy to use as an internet appliance, but this has its challenges… we’ll get there. Thanks for the feedback :slight_smile:

That’s interesting, we’ll update the wiki.


I maybe wrong, but I don’t think it’s a localization issue, as I said, other 5ghz systems show up just not mine…

I’ve not seen this issue with my other Raspberry PIs, and I got the same results after I set localization.
I would believe it’s something on my end, but everything everything that is connected to the 5Ghz side of the router works without issue… I will probably go ahead and reboot the router just to see thou.

I believe this is probably true with Android, which explains a lot honestly. Perhaps an updated wiki about using Android to setup the Vizy for the first time, would/could solve this. If the IP address of the Vizy is hard set, which I have to guess it is - then just publishing the IP would save some time as well.

I should have taken a screen shot - didn’t think about it, and not sure I really want “everyone” to know the WiFi password :slight_smile:
I was using Android 11, and the latest Chrome Mobile browser if that helps…
I could fake a password thou, and get a screen shot if it would help.

UPDATE: I did reboot my router - still not seeing my 5ghz, so I’m a bit confused by that. It is working on the 2ghz side of things.
Could it be RF overload from the 5ghz? I’m in the same room as the router, but 7 or 8 foot away, like I said, I’ve not had this problem with any of my other Raspberry PIs or device. So I’m not really sure what is going on.
Here are a few more screen shots of what it sees, PS: I’m the 1st one in the list.

As you can see in the last screen shot my 2ghz side of things is at -36dBm which is pretty good, so the only thing I can think of is I’m over driving the RF

Showing the same scan on my desktop the 5ghz is -29dBm…

I think the next step would be to move the vizy to another room and see if my thinking is right.


I see the other outputs – you’re saying that your 5G ssid isn’t being listed in iwlist. This is something we don’t have an answer for, but we’ll do some digging on this end.

I’m not sure if you’re seeing different networks listed from iwlist and the wifi dialog. Let me know if this is the case – it’ should be an easy fix it there’s a difference.

We’re going to also dig into the double password issue, see if we can repro in Android too.

Thanks much for the feedback!


Correct, I see a list which is more or less the same list from iwlist in the drop down. And other 5ghz networks are on the list, just not mine. I’m at a bit of a loss myself.

I moved the Vizy as far as I could get it in the house, and still my 5ghz isn’t showing up… so my idea of RF overload is probably not it either.

Rebooted my router, that didn’t change anything.
Making sure the localization is set correctly didn’t change it… I’m at a complete loss here.

ALSO I just tried to duplicate the double password issue so I could send a picture, and couldn’t get it to do that. Maybe it was in 0.0.75 firmware (?)

I do have an additional suggestion for mobile devices, it might be a good idea to have the site formatted better for a small screen.

WiFi has some configuration complexities and I admit that I’m not an expert (at all). It could be that your 5ghz frequencies are different than your neighbors’, and for configuration reasons either on Pi or router, the Pi isn’t able to see your router. I found this interesting-- https://raspberrypi.stackexchange.com/questions/107858/raspberry-pi-4-b-5ghz-wifi-access-point-problem

Anyway, just speculations… Thanks for the extra testing. :slight_smile:


Interestingly enough it seems some of my neighbors are on the same frequency. But the site, lead me down a path that I think has fixed it.
At least until I rebooted, then back to the same issue…
by typing iw reg set US into the cli, and then doing sudo iwlist wlan0 scan | grep 'ESSID'
I was able to see my 5ghz side of the router…unfortunately it reverted back to not working when I rebooted, so need to do a little more reading to figure out how to make it semi-permanent.

So it seems like your first thoughts about localization may have been correct, thou using raspi-config didn’t work (?) I know that one would need to go to the distro maintainers to see if there is a fix.

I found the solution (at least part of it) here: https://wireless.wiki.kernel.org/en/developers/regulatory/crda#changing_regulatory_domains

It’s a little bit of progress thou, at least “we” maybe getting an idea of what is going on.

There appears to be some conflict between wpa supplicant and networkmanager that needs to be addressed…

Try this – edit /etc/default/crda file and add “US” to the “REGDOMAIN=” line so it reads:


Then reboot.

We notice that if you run:

iw reg get

The country is actually unset. But after editing /etc/default/crda, the country is successfully set after reboot. Hopefully this fixes things on your end, but let us know what you find – we haven’t been able to reproduce in quite the way you have.


Seems to have fixed the issue. And I am now connected to the 5ghz side of things.

So let me ask, does the Vizy not use wpa_supplicant? I ask before if I look at the wpa_supplicat.conf file I don’t see my wifi credentials being store there. (the ifupdown.sh script looks like it may kill wpa_supplicant?)
also in vizy/ect folder I see a file called wifi.json file.
my only “worry” about this is the password is being stored in the clear, seems like this maybe a security risk for those that are worried about that type of thing.
But finding it in a file I wasn’t expecting made me wonder how the vizy is connecting.

At any rate, changing the /etc/default/crda file does appear to work for me.

As I think you said before, some of this is complex, your environment is not the same as mine, and even mine appears to have changed since the 1st time I tried to set this up (IE: I can’t seem to duplicate the doubled wifi password now…I’m not crazy thou, it did it I promise. :slight_smile: )

Vizy uses networkmanager (but networkmanager needs wpa_supplicant) You’re correct about wifi.json. The wifi password is stored unencrypted in this file. Securing these kinds of things is on our todo list.

That’s good news about /etc/default/crda. We’ll use this info to improve the wifi’s. Thanks for your help :slight_smile:


Happy to help in my small way, looking forward to more demos/examples this is where I’m hoping to get a better understanding of how the vision/ai works.
So really looking forward to what is next.

My initial power up was fairly smooth. A couple of comments that might help others:

  1. The Safari browser on my Mac (latest versions) won’t display the camera video. It does work fine using Firefox on the Mac instead.

  2. I initially used wired ethernet and tried to set up WiFi via VNC. That didn’t work for me. But when I followed the directions and used the WiFi menu via Vizy.local WiFi came right up.

Hi Ed,
We have tested Safari on IOS and it worked, but we’ll do some investigations with Safari on MacOS – thanks for the feedback. Did you update the Vizy software to version 0.0.76?

The Raspberry Pi desktop wifi config and Vizy’s wifi configuration aren’t fully compatible. I’ve been told that this is fixable, but I’m not sure when we’ll fix. :slight_smile:


Yes, I did update the Vizy software to the latest version. I’ve tested with Safari on my iPhone and it did work there.

I also tried it with Safari on a second Mac and the video wouldn’t display on that one either. It could be something in my set up. It’s not a big issue for me, since Firefox works.

You can get video on Safari on MacOS if you select "Disable ICE Candidate Restrictions from Develop->WebRTC:

But in general Chrome is recommended :slight_smile:


1 Like